Wi-Fi Issues
Incident Report for South Hadley Public Schools
Resolved
This incident has been resolved.
Posted Mar 03, 2023 - 15:45 EST
Investigating
We are currently investigating this issue.
Posted Mar 03, 2023 - 08:58 EST
This incident affected: SHPS-WiFi and SHPS-Network.